Monday, June 23, 2014

Sharp LC-65D93U blinking blue LED repair experience, inverter issues

A few hints for people facing a repair on Sharp LC-65D93U due to blinking power LED.

Meant to supplement the service manual and tell you a few things it doesn't (or at least not outright) and definitely not a complete guide on how to fix it.

Sharp LC-65D93U repaired by Coppell TV Repair for blue flashing LED

 

By now I forgot, but I believe we had to pull the unit out of the stand in order to take the back cover off.

Here's how it looks like on the inside, only protection of the bottom left inverter taken down:

Sharp LC-65D93U has 2 power boards and 6 inverter boards


Protection mode(s) : blinking LED and no response

Protection mode kicks in when the main board discovers something considered dangerous and shuts off the TV, locking it out.

There are two different protection modes I was able to figure out:

Fast blinking blue LED and slower blink of blue and green led simultaneously (or, more specifically, they start at the same time, but blink different number of times and report different codes).

The service manual gives good information on the various error codes reported when blue and green blink together, but does not say a lot about fast blue blinking, which is what we had: the TV would power on to a blue blinking LED and would not respond to anything whatsoever.

To get out of the protection mode, i.e. to tell the TV to attempt to start normally, do this (as per the service manual): disconnect from AC, wait until front LEDs stop blinking, then hold down the INPUT button on the side and, while holding it, press the VOLUME DOWN button (the very bottom one, I think it was  VOL DN); then, while holding both of them, connect the TV to AC power and keep on holding until you hear a relay click.


Troubleshooting hint: lots of feedback connections, module elimination approach not working

Sharp LC-65D93U is a high end TV and has lots of built-in protections and feedbacks from its various modules, which means you can't apply the classic approach of disconnecting a module to see if it prevents the TV from powering on.

Most LCD TVs would start all right if you disconnect an inverter - they'd just have dark screens - but this one won't.

You can't disconnect the T-CON board either and expect it to start with back light, but no image like most other LCDs.

The way to do it is to find the feedback signal and feed it false positive information, i.e. make it happy.


Symptom: Sharp LC-65D93U showing image for a second or two, then going back, then turning off and entering protection mode

Skipping another issue we had, we faced the above described behavior, which looked a lot like a bad inverter or bad CCFL or bad power.

But how to find which one?

First thing we did was disconnect a whole inverter, specifically the CCFLs on it, to see if it affected image.

It did, meaning we could see notable decrease of darkness in that area.

By this rude approach we found out that seeming all inverters DID work for a while, i.e. there was visible loss of brightness in the disconnected section for every of the 6 boards. We couldn't measure how much did we lose, though, so if a single lamp wasn't coming up we could not tell which one it would be.

And it wasn't even clear it was the inverters that were causing the shutdown to begin with.

Important note: the unit would NOT go into protection mode if you turn it off as soon as the display goes black. This simplifies testing when you'd need to power on the TV multiple times e.g. to find out which inverter/circuit is bad. If you  miss the moment you'd need to do the INPUT/VOL DOWN/AC POWER procedure again.


Starting up Sharp LC-65D93U without inverters (tricking the inverter feedback signal)

 The feedback from the inverters that causes the TV to shut down if they're not in place and working fine is the center BLUE wire on this connector located on INV4 (top right looking from the back):



What you need to do is pull out the middle BLUE cable and feed it 3.3V to make it happy. We did it by using a leg from a capacitor or resistor which we stuck in the blue cable's female ending and then in the 3.3V found on the BLACK wire on the connector itself:


There, if you do this (and it makes a good contact and inverters receive proper power from the power supply) it will make the main board happy even if the inverters fail due to a bad transformer or a bad CCFL or any other typical reason different from a major shortage on the power supply lines (which, if it were present, would not allow image to show up for a brief moment!).

Once we did this the TV did indeed stay on, confirming the suspicion that it was an inverter that has gone bad.

But which one of the 6?

Determining the bad inverter in  Sharp LC-65D93U and other LCD TVs
This is again nothing new and ground breaking and while rather universal is subject to some caveats and conditions which may make it not so widely applicable.

More on them later (if I remember), now for the meat: we were hoping that a lamp (and its power circuit) would not start or start and work much different from the rest.

Since CCFL lamps are powered with reasonably high voltage, high frequency AC voltage we hope to catch that voltage inductively and by comparison find which CCFL differs significantly from the rest.

We use a fairly good meter (I hear cheap Chinese meters can't really pick it up and I believe it, but I haven't tested it) - in my case a Fluke, in VAC mode, with pre-set range of 60 volts (this was useful so that it doesn't lose time to auto-adjust for the short time the inverters work) and our probes are between chassis and on wire of each inverter output going into the backlight assembly:


Polarity doesn't matter and for best reading it is important to try and get as much length of the wire in parallel to the probe's metal lead as possible.

Here's the Fluke's configuration (ignore the readings on both pictures; they were made while TV was off):
Again: AC voltage meter, pre-set range of 60V (that may depend on your device).

When the backlight activates the Fluke picked up voltage of anywhere between 8V and 15V depending on the lead/cable configuration (angle of placement, how much length in parallel they had etc.).

The voltage was there for a very brief time and to avoid TV shutdown and protection you can turn it off (the TV, not the Fluke) with the power button as soon as you get a reading.

On ONE of the boards there were NO READINGS or VERY LOW readings on one of the outputs.

After confirming the test a few times We thought we had found our bad guy.

And you should too.


Troubleshooting Sharp LC-65D93U backlight inverter

A reminder: this is not mean to cover all possible cases that could occur.

It is a free source, after all, take it or leave it, but do not criticize it :-)


Sharp LC-65D93U uses the following inverter boards:
  • RDENC2509TPZZ (INV1)
  • RDENC2510TPZZ (INV2)
  • RDENC2511TPZZ (INV3)
  • RDENC2512TPZZ (INV4)
  • RDENC2513TPZZ (INV5)
  • RDENC2514TPZZ (INV6)
(After you've identified the source of your problem you may want to first try and see if you can find a good working board through Google. It may save you time and nerves.)

As it turns out the inverters are made of TWO electrical circuits each, with THREE transformers in parallel in each circuit.

Transformers are the usual suspect in failed inverters and sure enough we spent some time on that too; I may write another article or extend this one on how to test the transformers on the boards, but I'll skip that now as the article is already getting too long.

In our case it turned out that it wasn't just ONE lamp that was not getting power for the brief moment when others were; it was THREE connectors (six lamps altogether) that were having the problem - every other on the faulty board.



We reasoned that if a single CCFL lamp was bad (or a connection to it) then it wouldn't affect the other two transformers circuits (the other two transformers) or if a transformer was bad, then unless it was bad in the primary winding it would also not affect the other two for the short time when everything worked and the output voltage would be picked up after the other two inverters.

I can't say with certainty how much of that reasoning is true - I am software developer by heart and just hacking my way into the hardware world - but I'd say that you should test the other transformers' outputs too.

If a single transformer output is lacking output then you have bad transformer or bad CCFL.

If all 3 are missing then it's got to be something BEFORE the transformers.

TO make long story short again, we've had TWO separate problems:

One was a 10 ohm resistor found in the gate of one of the driver transistors found in 2 pairs on each board.
The resistor has simply opened and the transistors could not drive the transformers.
Replacing the resistor made the board work.

The other (which we sort of caused while testing, i.e. after we got the TV to work reliably and started testing other boards on it) was one of the SOT-23 (or similar) transistors found in 2 pairs of 3 transistors (i.e. 2 groups of 6 transistors, 3 and 3 of a kind), which was lacking base/collector or base/emitter junction resistance as expected.
As of right now I do not remember what they were and I did not take pictures, unfortunately, but that's what it turned out being.

Again, that doesn't mean it can't be a transformer in your case.

As a result of our efforts we have some transformers available for purchase.

Check at www.coppelltvrepair.com or our eBay store.

Hope this helped. If it did please leave us positive feedback somewhere on the Web...we'd appreciate it!

Good luck!

0 comments:

Post a Comment